Упражнение 1: Запознаване с микропроцесорна система за развитие  на базата на едночиповия микроконтролер MSP430xG461x (TI)
1. Цел на упражнението:

Запознаване с архитектурата и функционалните възможности на развойна система;
Запознаване и работа с интегрираната програмна среда IAR Embedded Workbench;
Запознаване с програмния модел, видовете адресации и инструкции на едночиповия микроконтролер MSP430xG461x;

2. Опитна постановка:

Персонален компютър съвместим с IBM PC с Windows XP;
Развойна система ;

Интегрирана програмна среда IAR EW;

Връзка чрез стандартени кабели за USB и LPT порт на персоналния компютър;
3. Информационна част. 

3.1. Архитектура на микроконтролер MSP430xG461x
Микроконтролерите от семейство MSP430 съдържат 16-разрядно RISK CPU, периферни модули обединени посредством фон Нойманова организация с обща адресна шина (MAB) и шина за данни (MDB). Те притежават следните основни предимства:
· Архитектура с ултра ниско потребление на енергия;

· Висококачествена аналогова периферия за осъществяване на точни измервания и обработка;
· Силно развита таймерна система;
· Комуникация посредством асинхронни и синхронни интерфейси;

· Система за следене на захранващото напрежение;

· Гъвкава система за тактуване;

· Разширени възможности на векторното прекъсване.

Вградената логическа система за емулация в самия микроконтролер е достъпна посредством JTAG без използване на допълнителни системни ресурси. Блоковата схема на микроконтролера MSP430FG4618 е показана на фиг.1.
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Фиг.1. Блокова схема на микроконтролер MSP430FG4618.

3.2. Организация на CPU
Вграденото CPU отговаря на съвременните технологии на програмиране, като изчисляване на преходи, обработка на таблици, програмиране чрез използване на езици от високо ниво като С. CPU може да изпълнява адресации в цялото адресно пространство без използване на странична организация.

CPU има шестнадесет 16-разрядни регистъра. Регистри R0, R1, R2 и R3 имат специални функции, а регистри от R4 до R15 са с общо предназначение.
Рег. PC (R0) – програмен брояч (16 bit) – указва следващата за изпълнение инструкция. Всяка инструкция започва от четен адрес, затова последния бит на програмния брояч е нула.
Рег. SP (R1) – стеков указател (16 bit) – стековата памет се използва основно за съхраняване адреса на връщане от подпрограми или прекъсвания, а стековия указател показва адреса на последната запълнена клетка в стека. Зареждането и изтеглянето на информация от стека става по думи, затова последния бит на SP е нула.
Рег.SR (R2) – регистър на състоянието:
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Предназначението на отделните битове е показана в Табл.1.
Табл. 1.
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Overflow bit. This bit is set when the result of an arithmetic operation
overflows the signed-variable range.

ADD (.B) ,ADDC(.B) Set when:
Positive + Positive = Negative
Negative + Negative = Positive,
otherwise reset

SUB(.B),SUBC(.B),CMP(.B) Set when:
Positive — Negative = Negative
Negative - Positive = Positive,
otherwise reset

System clock generator 1. This bit, when set, turns off the SMCLK.

System clock generator 0. This bit, when set, turns off the DCO dc
generator, if DCOCLK is not used for MCLK or SMCLK.

Oscillator Off. This bit, when set, turns off the LFXT1 crystal oscillator,
when LFXT1CLK is not use for MCLK or SMCLK

CPU off. This bit, when set, turns off the CPU.

General interrupt enable. This bit, when set, enables maskable
interrupts. When reset, all maskable interrupts are disabled.

Negative bit. This bit is set when the result of a byte or word operation
is negative and cleared when the result is not negative.

Word operation: N is set to the value of bit 15 of the
result

Byte operation: N is set to the value of bit 7 of the
result

Zero bit. This bit is set when the result of a byte or word operation is 0
and cleared when the result is not 0.

Carry bit. This bit is set when the result of a byte or word operation
produced a carry and cleared when no carry occurred.





4) Рег. CG2 (R3) – генератор на константи (генерира най-често използваните 6 константи) – чрез него някои инструкции се емулират от други.

5) Рег. R4 ÷ R15 – регистри с общо предназначение.
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Фиг. 2. MSP430 – CPU и регистри.

3.3. Организация на паметта на MSP430F2xxx. 
Програмната памет, паметта за данни и паметта на периферните модули са разположени в едно общо 64 кВ адресно пространство, с изключение на новите модели от вида MSP430X (например подмножеството MSP430F2xxx), които имат 20-битова адресна шина и могат да адресират до 1MB памет. Всички регистри на CPU са 20-битови с изключение на статус регистъра SR, който е 16-битов (фиг. 3).
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Фиг. 3. MSP430F2xxx – CPU и регистри

Реализираната памет над адрес 0FFFFh е от тип Flash и може да се използва само като програмна памет. Начина на разпределение на паметта в първите 64kB е един и същ. Паметта включва регистри със специално предназначение (SFR), регистри за управление на периферията, памет за данни RAM, програмна Flash памет и информационна Flash памет (фиг. 4). Достъпът до програмния код посредством PC се изпълнява винаги по четни адреси. Данните могат да бъдат достъпни, както по байтово, така и по думи (два байта). Началният адрес на Flash паметта зависи от нейния обем. Крайният адрес е 0FFFFh, като последните 32 или повече байта (зависи от броя на периферните устройства) са предназначени за векторите на прекъсване. Крайният адрес на RAM паметта за данни зависи от реализирания обем на тази памет в конкретния микроконтролер.
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Фиг. 3. Карта на паметта на MSP430F2xxx.
Наличието на 20-битови регистри и адреси променя смисъла на думата “word”. Обикновено тя означава 16- бита. За да се запази нейният смисъл за данните тук се въвежда понятието адресна дума “address word”, която има 20 бита.
20-битовият PC в MSP430F2xxx при извикване на подпрограма ще заеме two words в стека. 12-те бита от едната дума ще останат неизползвани. Това се изпълнява с модифицираната инструкция calla  (fig.11.3) 
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Figure 11.3: Stack after calling a subroutine with (a) call in the MSP430 and
(b) calla in the MSP430X. Two words on the stack are needed to store the 20-bit

return address after calla.




Аналогично стои и въпроса при изпълнението на заявка на прекъсване. Тогава в стека се съхраняват PC и SR. Поради по-малката дължина на SR , той заема свободните 12 бита във втората дума на стека (fig.11.4).
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Figure 11.4: Stack before and after entering an interrupt service routine in the
MSP430X. The most significant 4 bits of the return address (from the PC) are stored
instead of the top 4 bits of the status register (SR), which contain no meaningful
data.




3.4. Режими на адресиране
Съществуват седем режима за адресация на операндите източник и четири адресации на операнда приемник. Чрез тях може да се адресира пълното адресно пространство. В табл.3 е дадена конфигурацията от битове за различните режими – As (източник) и Ad (приемник).
Табл. 3.
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3.4.1. Регистрова адресация 
Пример: Съдържанието на R10 се премества в рег. R11 . R10 не се променя.
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3.4.2. Индексна адресация
Пример: MOV 2(R5), 6(R6);
M(2+R5)→M(6+R6);
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MOV 2(RS), 6 (R6) MOV X (RS),Y(RE)
X=2
Y=6
Length: Two or three words
Operation: Move the contents of the source address (contents of R5 + 2)
to the destination address (contents of R6 + 6). The source
and destination registers (R5 and R6) are not affected. In
indexed mode, the program counter is incremented
automatically so that program execution continues with the
next instruction.
Comment: Valid for source and destination
Example: MOV  2(R5),6(R6);
Before: After:
Address Register Address Register
Space Space
oxxxxh | PC
OFF16h | 00006h R5[ 01080h|  OFF16h | 00006h Rs[ 01080h
OFF14h | 00002h Ré( 0108Ch OFF14h [ 00002h Re [ 0108Ch
OFF12h [ 04596h | PC OFF12h | 04596h
0108Ch
01094h | oxocxh +0006h_ 01094h [ Oxocxh
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3.4.3. Символна адресация
Пример: MOV EDE,TONI

;M(X+PC)→M(Y+PC). Ако EDE и TONI са символни имена, то X и Y са отмествания, които се добавят съответно към PC за получаване адресите на символните имена EDE и TONI.
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MOV EDE, TONT MOV X(PC),Y(PC)
X=EDE-PC
Y =TONI - PC

Length: Two or three words
Operation: Move the contents of the source address EDE (contents of
PC + X) to the destination address TONI (contents of PC +Y).
The words after the instruction contain the differences
between the PC and the source or destination addresses.
The assembler computes and inserts offsets X and Y
automatically. With symbolic mode, the program counter (PC)
is incremented automatically so that program execution
continues with the next instruction.
Comment: Valid for source and destination
Example: MOV EDE,TONI ;Source address EDE = 0F016h
;Dest. address TONI=01114h
Before: After:
Address Register Address Register
Space Space
Oxxch | PC
OFF16h | 011FEh 0FFt6h | 011FER
OFF14h [ OF102h 0FF14h | OF102h
OFF12h [ 04090h | PC OFF12h | 04090h
OFF14h
oFo1gh | Oxxxxh _+O0F102h _ 0F018h [ Oxxxh
o0Fo16h | 0A123h OFOTBh oroten [ oAt2an
0Fo14h | Oxxoh 0F014h [ Oxooh
OFF16h
01116h | Ox00th +011FEh 01116h [ Ox00h
01114h | 05555h oTTan 01114h [0A123n
01112h | Oxoah o1112h [ Oxooch





3.4.4. Абсолютна адресация
Пример: MOV &MEM, &DAT
; M(MEM)→M(DAT);
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MOV &EDE, RTONI MOV X(0),%(0)
X =EDE
Y =TONI

Length: Two or three words

Operation: ~ Move the contents of the source address EDE to the

destination address TONI. The words after the instruction
contain the absolute address of the source and destination
addresses. With absolute mode, the PC is incremented
automatically so that program execution continues with the
next instruction.

Comment:  Valid for source and destination
Example: MOV &EDE, &TONI ;Source address EDE=0F016h,
jdest. address TONI=01114h
Before: After:
Address Register Address Reglster
Space Space
oxxeh | PC
OFFten | 0111ah OFF16h | 01114n
OFF1an | OF016h OFF14n | OF016n
OFF12n | 042920 | PC OFF12n | 042020
OF018h | Oxxeh OF018h [ Oxxxh
OF016h | 0A123h OFot6h | 0A1230
OFo1dn | Oxoxh OF014n | Ok
ottteh | oxoh ottt | oxoxh
oft14n | 01234n 01114n | 0A123h
ott1zh | oxoxh ottizh | oxexh

This address mode is mainly for hardware peripheral modules that are located
at an absolute, fixed address. These are addressed with absolute mode to
ensure software transportability (for example, position-independent code).




3.4.5. Индиректна адресация
Пример: MOV @R10, 0(R11)

;M(R10)→M(R11+0);
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MOV @R10,0 (R11) MOV GR10,0(R11)
Length: One or two words
Operation: Move the contents of the source address (contents of R10) to
the destination address (contents of R11). The registers are
not modified.
Comment: Valid only for source operand. The substitute for destination
operand is O(Rd).
Example: MOV.B @R10,0(R11)
Before: . After: .
Address Register Address Register
Space Space
0xxxxh Ooxxxxh | PC
OFF16h [ 0000h R10| OFA33h [ OFF16h [ 0000h R10 [ OFA33h
OFF14h | 04AEBh | PC R11| 002A7h [ OFF14h [ 04AEBh R11| 002A7h
OFF12h | Oxxxxh OFF12h | Oxxxxh
OFA34h | Oxxxxh OFA34h | Oxxxxh
OFA32h | 05BC1h OFA32h [ 05BC1h
OFA30h | 0xxxxh OFA30h | Oxxxxh
002A8h Oxxh 002A8h Oxxh
002A7h [ 012h 002A7h | 05Bh
002A6h | Oxxh 002A6h Oxxh





3.4.6. Индиректна автоинкрементираща адресация
Пример: MOV @R10+, 0(R11)

;M(R10)→R11;

R10+2→R10
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Length: One or two words

Operation:  Move the conterts of the source address (contents of R10) to
the destination address (contents of R11). Register R10 is
incremented by 1 for a byte operation, or 2 for a word
operation after the fetch; it points to the next address without
any overhead. This is useful for table processing.

Comment:  Valid only for source operand. The substitute for destination
operand is O(Rd) plus second instruction INCD Rd.

Example: MOV GR1O+,0(R11)

Before: \fter:

Address Register Address Register
Space Space

OFF18h | Ox0cxh OFF18h | Oxoxh | PC

OFF16h | 00000h R10| OFA32h | OFF16h| 00000h R10| OFA34h

OFF14h | 04ABBh | PC R11| 010A8h| OFF14h | 04ABBh R11| 010A8h

OFF12h | Oxoxh OFF12h | Oxxooh

OFA34h | Oxxoxh OFA34h | Oxxxxh

0FA32h | 05BC1h OFA32h | 05BC1h

OFA30h | Oxxxxh OFA30h | Oxxxxh

010AAR | Oxxxxh 010AAN | Oxxxxh

010A8h | 01234h 010A8h | 05BC1h

010A8h | Oxxxxh 010A6h | Oxxxxh





3.4.7. Непосредствена адресация
Пример: MOV #45, MEM

;#45→M(MEM);
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MOV #45h, TONT MOV @PC+,X (PC)
45
X =TONI - PC
Length: Two or three words

Itis one word less if a constant of CG1 or CG2 can be used.

Operation: Move the immediate constant 45h, which is contained in the
word following the instruction, to destination address TONI.
When fetching the source, the program counter points to the
word following the instruction and moves the contents to the

destination.
Comment: Valid only for a source operand.
Example: MOV  #45h, TONI
Before: After:
Address Register Address Register
Space Space
OFF18h | Oxxxxh | PC
OFF16h [ 01192h OFF16h [ 01192h
OFF14h | 00045h OFF14h [ 00045h
OFF12h | 040Boh | PC OFF12h | 040BOh
OFF16h
010AAh 0xx00ch +01192h _ 010AAh | Oxxxxh
o10Ash | 01234h 010A8h  510pgh [ 00045h
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3.5. Инструкции на микроконтролера
Микроконтролер MSP430 има 27 вградени инструкции и 24 емулирани инструкции. Емулираните инструкции нямат свой код, а се представят с вградените при асемблирането. Те са въведени единствено за удобство при писането и четенето на асемблерските програми. Използването на емулираните команди не води до увеличаване обема на кода или намаляване на производителността.
Съществуват три формата на вградените инструкции: инструкции с два операнда; инструкции с един операнд; инструкции за преход. Всички инструкции с един или два операнда могат да се изпълняват, както върху байтове, така и върху думи (използват се съответно разширения  «.B» и  «.W»). Източникът и получателя в инструкциите се определят със следните полета:
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Формат на инструкция с два операнда: 
[image: image18.png]15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0




Формат на инструкция с един операнд: 
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За инструкцията CALL са възможни всичките методи за адресация. 

Формат на инструкция за преход: 
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Условните преходи осигуряват разклонения в програмата и не указват влияния върху статус битовете. Възможният диапазон за преход е от 10-битово число в допълнителен код (offset от -512 до +511) относно текущата стойност на PC:
PCnew = PCold +2 + offset x 2
Поради разширеното адресно пространство на MSP430X се налага добавянето на още няколко инструкции: addx.a, addx.w, addx.b съответно за работа с 20 16 и 8 бите. При работа с подпрограми и прекъсвания – calla, reta, retia, bra и др. Следва наборът от инструкции за микроконтролера MSP430:
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3.6. Интегрирана програмна среда IAR Embedded Workbench (IAR EW)

IAR EW е гъвкава програмна развойна среда, която позволява разработване и управление на вградени приложни програми за широк спектър целеви микроконтролери. IAR EW430 представлява софтуерна платформа, интегрираща:

- Оптимизиран IAR MSP430 C/C++ компилатор;

- IAR MSP 430 Асемблер;
- IAR XLINK линкер;

- XAR Library Builder и XLIB Librarian;

- Текстов редактор;

- Менажер на проектите с MAKE – utility;

- Дебъгваща  програма – IAR C-SPY Simulator, IAR C-SPY® FET debugger.
IAR EW обезпечава удобен Windows – интерфейс с възможност за управление на всички модули от програмния проект – С-файлове, асемблерски файлове, хедър-файлове и др. Създава се работнo пространство (workspace), което съдържа един или няколко проекта (project). Сорс-файловете могат да се обединят в група или да се добавят директно към проекта. На фиг.4 е показан основният екран на IAR Embedded Workbench for MSP430. В лявата част на екрана се намира Workspace window, който структурата на набора от файлове, с които потребителя работи в даден момент. Тази съвкупност от файлове се нарича проект (project).
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Фиг.4. Екран на IAR Embedded Workbench IDE.

В дясно се намира редакторския прозорец (Editor window). На него може да се зареди и редактира всеки един от файловете на проекта. Под тези два прозореца се намира прозореца за съобщения (Messages window). На него се извеждат съобщение от работата на отделните инструменти на средата, както и съобщения за грешки.
В горната част на екрана се намират падащи менюта (Menu bar) за управление на развойната среда, а под тях и бутони за бързо избиране (Toolbar). Показани са функциите на отделните бутони.
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3.6. Създаване на приложен проект с IAR EW
Препоръчително е преди създаването на приложния проект да се създаде папка, в която ще се съхраняват всички файлове на проекта.
Стартиране на средата IAR EW MSP430: Start(IAR Systems>IAR Embedded Workbench Kickstart for MSP430 V4>IAR Embedded Workbench.
Създаване на нов проект: Project>Create New Project. В отварящото се меню избираме Tool chain: MSP430 и от Progect templstes>Empty project. Потвърждава се с OK. 
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Така създадения проект трябва да се съхрани. От появилия се прозорец Save as се избира желаната папка и се задава име на проекта, например proj1.Така създадения проект се добавя в Workspace window.
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Съществуват два варианта за изграждане на проекта: Debug и Release. При настройка и тестване на проекта се използва Debug. Символът „звезда” след избрания режим показва, че е необходимо да се съхрани така създаденото работно пространство Workspace. Избира се File>Save Workspace и се определя директорията (вече създаде за проекта), където да се съхрани workspace file. Името на Workspace file може да съвпада или не с това на проекта, но разширението му винаги е eww.
Следва добавянето на source files към проекта. В конкретния проект алтернативно ще светват два светодиода включени към порт две (P2.1-P2.2). Текстът на програмата на С е даден в папката на упражнението.
Програмата се въвежда в Editor window след избора File>New>File. Тя съдържа следните основни моменти:

1. Включване на хедър файла <msp430x46x.h>, отговарящ на микроконтролера, с който работим;
2. Спиране на Watchdog timer;

3. Чрез регистъра за посока на порт две P2DIR се определят изводите на порта които са изходи, чрез запис на единици в отделните битове;
4. В изходния регистър на порт седем P2OUT се записва 0х02 , което ще запали един от светодиодите (виж схемата в приложението) ;

5. Влиза се в един безкраен цикъл, в който посредством инструкция „изключващо ИЛИ” се превключват светодиодите. Времето за светене се реализира чрез декрементиране на променливата i.
За съхраняване на файла се използва меню File>Save as. Избира се директорията на проекта и файла се записва под желаното име, например demo1.c . Създаването и съхраняването на файла, все още не означава, че той е включен към проекта. Затова от меню Project>Add Files се добавя така създадения файл към проекта. По същия начин, ако е необходимо, могат да се добавят още файлове.
Следва конфигурирането на проекта, като се маркира името на проекта в Workspace window и се избира Project > Options…. От появилия се прозорец се избира конкретния модел на микроконтролера, в случая MSP430FG4618. 
От страниците на General Options се избират:


Target



Device: msp430FG4618


Output



Output file: Executable


Library Configuration

Library: Nornal DLIB
От страниците на C/C++ Compiler се избират:


Language



Language: C



Optimization


Level: None


Output



Generate debug information



List




Output list file: Assembler mnemonics

От страниците на Linker се избират:



Output



Format: Debug information for C-SPY
With runtime control modules, and with I/O emulation modules



List


Generate linker listing, Segment map and Module map
От страниците на Debugger се избират (в режим Simulator):


Driver



Simulator


Run to



main
Последният избор означава, че тестването на програмата ще се СИМУЛИРА в средата на персоналния компютър.
От страниците на Debugger се избират (в режим FET Debugger – тестване на програмата върху експерименталната платка):



Driver



FET Debugger


Run to



main


oт подстраницата FET Debugger>Setup:


Connection


Texas Instrument USB-IF, Automatic.
След избора на посочените опции, те се потвърждават с OK. 

След настройката на проекта следва неговото компилиране и свързване в изпълним файл. За целта се избира Project>Compile . При свързването на проекта в изпълним файл се използва стандартния Linker command file за избрания микроконтролер (намира се в директорията Config на мястото където е инсталирана средата). След завършване на процесите в Message window се извеждат съобщения за тяхната работа.
Тъй като е избран режим Debug, в Debug директорията се създават поддиректории List, Obj и Exe. В тях се намират съответните файлове на проекта. Същите се появяват и в Workspace window. С двукратен избор на мишката същите могат да се наблюдават в Editor window. Изпълнимият файл, който се намира в директорията Exe , ще се използва от IAR C-SPY® Debugger в режим simulator.
За да не се загуби полученият резултат, преди симулацията е необходимо да се съхрани Workspace. За целта се избира File>Save Workspace и се потвърждава с OK.
Отворете demo1.lst в Editor window, чрез двукратен избор (double-clicking) на файла. Той съдържа освен текста на програмата и следната допълнителна информация:
В заглавната част (header) е показана версията на продукта, къде са създадени файловете и командната линия.

В тялото (body) на файла са показани асемблерския код и двойчния код на всеки оператор, както и разполагането на променливите в различните сегменти.

В края (end) на файла са посочени размерите на stack, code, и data memory, както и съобщенията за грешки и предупреждения.
За да се извършва автоматична актуализация на разглежданите файлове в Editor window изберете Tools>Options и след отваряне на диалоговия прозорец IDE Options изберете Editor. Маркирайте режима Scan for Changed Files. 
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В директорията EXE се намира изпълнимия файл proj1.d43 за симулация, в който е добавена информация за дебъгване на програмата.
3.7. Тестване на програма посредством Симулация.
След като предварително е избран режим на дебъгване СИМУЛАЦИЯ, то той се стартира с Project>Debug. Алтернативно стартиране може да се избере с бутона Debugger. IAR C-SPY Debugger стартира програмата proj1.d43. На екрана се появява дисасемблираната програма заедно с операторите на С. Извършва се първоначална инициализация (установяване стойностите на PC и SP). Указателят за изпълнение на програмата (зеленият ред) се установява на първата асемблерска инструкция от главната програма main. От падащото меню View може да се избере за наблюдение: Registers, Memory, Watch и др. В прозореца Watch могат да се наблюдават променливи или чрез изписване имената на променливите или чрез тяхното маркиране и използване на контексното меню за добавяне. От падащото меню Debug или чрез бутоните може да се започне постъпково изпълнение на програмата. След изпълнение на няколко стъпки на екрана се получава:
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Действието на бутоните при тестване изпълнението на програмата е:
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По време на тестването на програмата могат да се поставят точки на прекъсване breakpoint чрез двукратен избор в ляво от реда. Редът, на който е избрана точката на прекъсване се оцветява в червено. Чрез контексното меню могат да се поставят условия, при които изпълнението на програмата да спре на точката на прекъсване. С избора на Debug>Go или с бутона Go се продължава изпълнението на програмата.
Извежданата информация в Disassembly window по време на тестване е:
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4. Задачи за изпълнение
4.1. Запознаване с възможмостите на интегрираната програмна среда IAR Embedded Workbench за микроконтролер MSP430.

4.2. Създаване на проект и тестване на демонстрационната програма demo1.c в режим СИМУЛАЦИЯ.
4.3. Модифициране програмата demo1.c, като тестването на програмата да се извърщи в експерименталния модул.

4.4. Модифицирайте програмата като последователно се включи и светодиод LED4, който е свързан към линия .
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